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Utilizing GIS Data Workshop Series
Mapping Gun Violence in the US

GIS Resources:
GIS Listserv: https://listserv.miami.edu/scripts/wa.exe?SUBED1=gis&A=1 
UM Library GIS Guide: http://sp.library.miami.edu/subjects/gis/

Scenario:
Gun violence in the US is a topic surrounded with much controversy and points of view. You are a researcher looking for data showing where gun violence occurs in the country and want to explore relationships between crime and access to guns.
Outcomes:
This workshop will show you how to find current gun violence related data, map it in a GIS, and analyze relationships between gun access and crime. This workshop will focus on geocoding as a means to bring data into your GIS.
Skills Covered:
Internet: Data searching, tabular data extraction.
Excel: Tabular data manipulation in Excel, formatting table for use in ArcGIS.
ArcGIS: Geocoding addresses (via ArcGIS Online geocoder and creating your own address locator from Census Tigerline files), manual re-matching, table join, near analysis, buffer, spatial join, and symbology.
Download Tutorial Data for this Workshop:
1.  Go to Subjects Plus guide: http://sp.library.miami.edu/subjects/gis 
2. Download the Dataset for the Gun Violence Workshop (Right-click> Save Target As> Save to C:\temp)
Extract the Data to the c:\Temp folder
1. Browse to the c:\Temp folder, where you saved the Data
2. Right-click on the EX01_World.zip and select Extract All…
3. Accept all defaults to extract the data file to C:\Temp
I. Mass Shootings in the US
A. Acquire and modify Mass Shooting Data (10 min)
1. [image: ]Go to web site: http://www.gunviolencearchive.org/ 

2. Click the Reports tab, then select Mass Shootings 2015, select “export as csv” button and download csv file for it.

3. Open csv file in Excel, select all cells and fit to column width (Home>Format>AutoFit Column Width). If you were not able to download the file, use the existing one from the Pre-Baked folder (export-455a79db-1394-4471-836b-000aacbbf764.csv).

4. [image: ]Edit file by deleting ‘# ’ in the killed and injured fields (can’t have special characters in table headers in ArcGIS). Also edit “City or County” and “Incident Date” headers to “Cty_or_Cnty” and “Inc_Date” and delete the Operations column.

5. To improve matching for Geocoding, edit the Address field and remove any “block of” text (Highlight Address field>Home>Find and Select>Replace. In “Find what” put ‘block of ’ and leave “Replace with” blank. Then click Replace All and close; 136 replacements should be made.)

6. Save as csv file called US_Mass_Shootings_2015 to your C:/Temp/Gun_Violence folder.

B. Load Mass Shooting data into ArcGIS and Geocode (45 min)
	Geocoding consists of plotting addresses or locations as a point layer in ArcGIS. There is no limit on the number of addresses or locations and it is best to have addresses in separate fields from city, country, etc. A match of 85% for an address list is considered pretty good.
1. Open US_Mass_Shootings.mxd project file from C:/Temp> Gun_Violence Folder.
2. Add the modified US_Mass_Shooting_2015.csv file (add from Prebaked folder if you were not able to modify it in time for this step).
3. Open Attribute table (Right click US Mass Shootings_2015.csv from Table of Contents and open table).
4. Examine table to make sure all data is formatted correctly (date field, text fields, number fields, etc.).
5. [image: ]Obtain an ArcGIS Online account if you do not already have one (see instructor for an account).
6. Sign in to ArcGIS Online in ArcMap (File>Sign In).
7. Right click the US_Mass_Shootings_2015.csv file in the Table of Contents and select “Geocode Addresses.”
8. [image: ]In the dialog window, select “World Geocode Service (ArcGIS Online) as the geocoding service and click OK.
9. In the Geocoding dialog box, match the following fields:
Address: Address
City: Cty_or_Cnty
SubRegion: Cty_or_Cnty
Region: State
10. For Output file, create file called US_Mass_Shootings_2015.shp to the Gun_Violence>Data folder. Click OK in the Geocoding dialog box to start the geocoding process.
11. There should be a match of 85% (282 out of 330 addresses), 9% tied (29 out of 330 addresses), and 6% unmatched (19 out of 330 addresses). Click “rematch” to manually match the addresses that tied or were unmatched.
12. In the Interactive Rematch window, select “matched addresses with candidates tied” in the show results box in the upper left corner of the window. Select each of the 29 tied results and then select the address from the candidate list in the bottom of the window that best corresponds/matches it, then click the match button on the lower right corner of the window. Repeat this process for all 29 tied and 16 unmatched addresses.
13. To repeat the process, you can select the right arrow in the count box below the results to advance to the next record. Directly below the count box will be selected address just showing the match fields.
14. For (record 12 of 29) tied address “E. 153rd St. and the Grand Concourse”, change to “E. 153rd St. and Grand Concourse” then click search. This will give more accurate candidates than just Bronx, NY.
15. For tied address record 16, change to Boulder Rd.
16. For tied record 18, change to Smiley Cir.
17. For tied record 28, change to 4900 Styer St. Orlando, FL.
18. When done matching the tied addresses, switch the show results selection to “Unmatched Addresses” and repeat manual matching process.
19. For unmatched record 1, delete (Goulds) from City field (just leave Miami)
20. For unmatched record 2, replace City field with Miami.
21. For unmatched record 3, replace City field with Brooklyn.
22. For unmatched record 4, replace City field with Pittsburgh.
23. For unmatched record 5, delete (Fairmount) from City field (just leave Cincinnati) and click search.
24. For unmatched record 6, change city to Conway (Horry County, SC).
25. For unmatched record 7, change city to Cedar Bluff (Cherokee County, AL).
26. For unmatched record 8, change city to Cincinnati (delete Evanston).
27. For unmatched record 9, leave Greenwood and delete Excelsior in City field.
28. For unmatched record 10, leave Minneapolis and delete Brooklyn Center in City field.
29. For unmatched record 11, leave Pine Hills and delete Orlando for City. Right click the top scoring candidate for Pine Hills, FL and select Zoom To. Select the “Pick Address from Map” button, then Right Click the area of Pine Hills that intersects with SR 408 on the map and click “Pick Address”.
30. For unmatched record 12, leave Grulla and delete (La Grulla) in City field.
31. For unmatched record 13, leave Barre and delete (Berlin) in City field.
32. For unmatched record 14, leave Cincinnati and delete Westwood in City field.
33. For unmatched record 15, leave New York and delete Manhattan in City field.
34. For unmatched record 16, leave Pittsburgh and delete Wilkinsburg in City field.
35. For unmatched record 17, leave Beachwood and delete Warrensville Heights.
36. For unmatched record 18, leave New York and delete Manhattan in City field.
37. For unmatched record 19, enter New York for City field.
38. You should now have 330 matched records. Close the Interactive Rematch window.
C. Cartography for Mass Shooting (5 min)
[image: ]  Site Lethality Map
1.  We will first make a map of mass shootings in the US by points.
2. Before symbolization, we want to come up with a single value that best estimates the lethality of these mass shooting attacks. Since there are separate fields for killed and injured, we are going to weight the killed filed with a count of three for every one killed so it can be combined with the injured count to come up with an estimated lethality index.
3. [image: ]Open the table for the US_Mass_Shootings_2015 layer (Right click in Table of Contents>Open Attribute Table).
4. Click the Table Menu and select Add Field. Add two short integer fields called Kill_Wght and Lethal. 
5. Start Editing the US_Mass_Shooting_2015 layer and open the raster calculator for the Kill_Wght field (Right click Kill_Wght header and click “Field Calculator” and enter the following expression: [Killed] *3 and click OK.
6. After making sure Kill_Wght calculated correctly, open the field calculator again for the Lethal field and enter the following expression: [Kill_Wght] + [Injured]. 
7. Now that we have a single value field to map mass shooting lethality, Right click the US_Mass_Shooting_2015 layer, go to Properties>Symbology, then select Quantities>Graduated Symbols. If you did not achieve the added fields in the last few steps, add the US_Mass_Shootings_2015_Lethality.shp file from the Pre-Baked folder.
8. Select “Lethal” as the Value field, change color to red, make 40% transparent (Display tab) and click OK. 
D. State Lethality Map (20 min)
1. [image: ]Suppose we now want to determine and map out the mass shooting by State rather than by specific address. We will have to create a State polygon layer with the lethality summarized for each state.
2. Add the State layer from ArcCatalog by dragging the layer from the Gun_Violence>Data folder into the data frame.
3. In the Search Tab, type Summary and open the Summary Statistics tool.
4. [image: ]In the Summary Statistics dialog box, select US_Mass_Shootings_2015_Lethality as the Input Table, enter Lethal_State as the output file (put in C:/Temp/Gun_Violence/Data folder), choose “Lethal” as the Statistics Field (SUM as Statistics Type), and “State” as case field. Run the Summary Statistics and it should automatically add the Lethal_State table to the Table of Contents.
5. Open the Lethal_State table from the Table of Contents (Right Click> Open Table). The table should contain a Sum_Lethal field and Frequency field by State. 
6. Join the Sum Lethal table to the State layer (Right click State layer>Joins & Relates>Join. Use “State Name” in the State layer and “State” in the Lethal_State table as the join field and keep all records. Save the State layer as “Lethal_States_Join.shp” in the C:/Temp/Gun_Violence/Data folder (Right click States in TOC>Data>Export Data.)
7. [image: ]Symbolize the States_Lethal_Join layer (Right click in TOC>Properties>Symbology) using Quantities>Graduated colors and select SUM_LETHAL as the Value. Chose red color ramp, choose 7 classes, and reduce decimal places for labels to zero by clicking on the label header>Format Labels. Select the Labels tab and use SUM_LETHAL as the label field (be sure to check “Label features in this layer.” Click OK for the Properties.
8. You can see that California, Texas, New York, Georgia, Illinois, and Florida are the 6 most lethal states when it comes to mass shootings.
9. Go back to the properties for the Lethal_States_Join layer and keep everything the same except change SUM_LETHAL to FREQUENCY for the symbology value and label field. You can see that California, Illinois, New York, Georgia, Florida, and Pennsylvania had the most frequent mass shootings for 2015.
10.  Change symbology for US_Mass_Shootings_2015 layer to a gun symbol (Weapons, Law, Gun) by searching for gun in the symbol selector. Change the background yellow circle to no color under Edit Symbol and change to size 12 and turn on layer. This will overlay the distribution of mass shootings in each state over the lethality choropleth map.

E. Heat Map of Mass Shooting Lethality (5 min)
1. [image: ]Suppose you wanted to show a smoother map of the lethality of mass shooting distribution across the US than the point data.
2. Go to Customize on the top toolbar, then Extensions, and ensure that the Spatial Analyst box is checked.
3. Search for “Kernel Density” in the Search tab and open the tool.
4. Select US_Mass_Shootings_2015_Lethality as the Input point or polyline features, “Lethal” as the Population field, and call the Output Raster Lethal_Ker. Select Environments>Processing Extent and choose “Same as layer Lethal_States_Join.” Click OK for Environmental Settings. Change Output Cell Size to 0.1. Click OK for the Kernel Density Tool.
5. Symbolize Lethal_Ker raster with an Orange Color Ramp and change transparency to 40%.

F. Tapestry Segmentation Tract per Mass Shooting Incident Location Analysis/Map (20 min)
1. [image: ]Suppose we want to determine what kind of neighborhoods in which the 2015 mass shootings occurred. 
2. Add the Tapseg_14_Tr layer from the Data folder to the data frame. This contains census tracts with the dominant tapestry segmentation for the entire US at census tract level.
3. Search for and open the “Spatial Join” tool in the Search tab.
4. Select US_Mass_Shootings_2015_Lethality as the Target Feature, Tapseg_14_Tr as the Join Feature, keep the one to one join operation, and choose the WITHIN map option. Save Output Feature Class as Mass_Shoot_Tapseg.shp in the Data folder.
5. In the Field map of Join Features Option, remove all the fields from Tapseg_14_Tr except TSEGNAME (Can’t select range, so have to delete one by one).
6. Add field to the Mass_Shoot_Tapseg layer called “Count” as a short Integer.
7. [image: ]Start editing Mass_Shoot_Tapseg, open the Field Calculator for the Count Field and populate each row with the value of 1. Stop editing and save edits.
8. Search for and open the Summary Statistics tool in the Search tab.
9. Select Mass_Shoot_Tapseg as the Input Table; Call output table Mass_Shoot_Tapseg_Sum; Choose Count as the Statistics field (SUM for statistics type); Make TSEGNAME the Case Field. Click OK.
10. Open table for Mass_Shoot_Tapseg_Sum table and sort SUM_COUNT descending. You can see that Modest Income Homes (52), City Commons (37), and Hardscrabble Road (14) are the top three tapestry segments in which mass shootings occur.
11. Symbolize the Mass_Shoot_Tapseg layer as Categories with TSEGNAME as the Value Field (Add All Values). As you can see, there appear to be too much Tapestry Segments to make sense of the map.
Challenge: Try to make a map that communicates the type of neighborhoods in which the mass shootings occurred across the US.

II. Crime and Gun Access in Miami Dade County
A. Build Address Locator to Geocode Crime in Miami Dade County
1. In a browser, navigate to https://www.census.gov/cgi-bin/geo/shapefiles/index.php to download Miami Dade county Tigerline files.
2. Choose 2015 as Select Year and Relationship Files under Select a Layer Type then click submit.
3. Under Address-Range Feature Shapefile, select Florida for State and Miami Dade for County, then click download (shapefile should be called tl_2015_12086_addrfeat) and unzip to C:/Temp/Gun_Violence folder.
4. Click the browser back button to go to the previous web page, keep the year 2015, but change the Select Layer Type to Places and click submit. Select Florida for State and click download (shapefile should be called tl_2015_12_place) and unzip to C:/Temp/Gun_Violence folder.
5. Open up the ArcGIS project called Miami_Dade_Gun_Crime.mxd in the C:/Temp/Gun_Violence directory.
6. Add the tl_2015_12086_addrfeat and tl_2015_12_place files you downloaded from the Census in the Gun_Violence folder to ArcMap.
7. In order to have cities and places as a matching option for our address locator, we are going to assign place names to each street segment in Miami Dade County. In the Search tab, type in Spatial Join and open up the Spatial Join (Analysis) tool.
8. In the Spatial Join dialog box, enter the following:
Target Features: tl_2015_12086_addrfeat
Join Features: tl_2015_12_place
Output Feature Class: C:/Temp/Gun_Violence/ Miami_Dade_Streets_Places.shp.
Join Operation: one to one
Field Map of Join Features: delete all tl_2015_12_place fields except Name
Match Option: Intersect
Click OK.
9. Open the Attribute table for the resulting Miami_Dade_Streets_Places file and scroll to the right side of the table to make sure the Name field has been joined.
10. Start editing the Miami_Dade_Streets_Places layer, use the Select by Attributes tool and enter the following query for the Miami_Dade_Streets_Places layer: "NAME" = ' '. This selects all the streets that were not assigned a Place name. Right click the Name field in the Attribute table, open the Field Calculator and enter “Miami” (with quotes). This assigns all the streets without a place the Miami place name. Stop editing and save edits.
11. [image: ]Now you have a good dataset to build your Address Locator for Miami Dade County. In the Catalog tab, right click the Gun_Violence folder and go to New>Address Locator.
12. In the Create Address Locator dialog box, enter the following:
Address Locator Style: US Addresses Dual Range
Reference Data: Miami_Dade_Streets_Places; Role: Primary
Field Map:
	From Left: LROMHN
	To Left:	LTOHN
	From Right: RFROMHN
	To Right: RTOHN
	Street name: FULLNAME
	Left/Right City or Place: NAME
Output Address Locator: C:/Temp/Gun_Violence/ Miami_Dade_Streets_Places
Click OK. You should now have an address locator for Miami Dade County.

B. Download Miami-Dade Crime and Gun Access Data
1. Go to the following Web site: http://www.crimemapping.com/map/fl/miami-dadecounty 
2. Change the date range from 01/29/2015 to 02/10/2016 and click Apply. Click the Detailed Report icon to get a table of addresses/intersections where the crimes occurred.
3. Select/highlight the entire table in the web browser, copy it, and then right-click and choose paste (match destination formatting).
4. In Excel, click Format>Auto fit Column Width. Delete rows 1, 2, and 4 and column A (Type). Remove all the special characters in the headings (: or #).
5. Highlight column C (Location), then use the Find and Replace Tool in Excel (Home>Find & Select) to remove all instances of “block” as this will cause matching problems during geocoding. Over 500 instances should be replaced with a blank. 
6. Also remove –Dade Police and Police from the Agency field, then change the header name from Agency to City. Name the Excel tab the data is in “Crime”. Save As a CSV file C:/Temp/Gun_Violence/Miami_Dade_Crime.csv.
	
C. Geocode Miami-Dade Crime Data 
1. Add the Miami_Dade_Crime.csv to ArcMap.
2. Right click the Miami_Dade_Crime table in the ArcMap Table of Contents and select Geocode Addresses, then select the Miami_Dade_Streets_Places Address Locator (add it if it doesn’t show up in the list) and click OK.
3. In the Geocode dialog box, enter the following:
	Radio Button: Multiple Fields
	Street or Intersection: Location
	City or Place name: City
	Output Shapefile or Feature Class: C:/Temp/Gun_Violence/Census_Geocode_Miami_Crime.shp 
In the Geocoding Options, make the Minimum Match Score 60 and click OK. Click OK again to run the geocoding. After processing, click close.

D. Analyze Relationship between Crime and Access to Guns
1. Add the Gun_Stores layer to ArcMap from the C:/Temp/Gun_Violence/Data directory.
2. Search for and open the Near (Analysis) tool from the Search tab. Enter the following in the dialog box:
	Input Features: Census_Geocode_Miami_Crime
	Near Features: Gun_Stores
	Method: Planar
Click OK. This will add the FID of the nearest Gun_Store and distance to it in the Census_Geocode_Miami_Crime layer.
3. Right click the Census_Geocode_Miami_Crime layer and select Joins and Relates>Join. Join the Gun_Stores FID to the Census_Geocode_Miami_Crime layer’s Near_FID field and click OK. Resave file as Census_Geocode_Miami_Crime_Near.shp in the C:/Temp/Gun_Violence directory.
[bookmark: _GoBack]4. Add an Integer field called “Count” to the Census_Geocode_Miami_Crime_Near layer then use the field calculator to enter a value of 1 to each record in this new filed. Stop editing and save edits.
5. Search for and open the Summary Statistics (Analysis) tool in the Search tab enter the following:
	Input Table: Census_Geocode_Miami_Crime_Near
	Output Table: C:\Temp\Gun_Violence\Pre_Baked\near_stats
	Statistics Field: Count; Statistics Type: Sum
	Case Field: CONAME
	Click OK.
6. Right click Gun_Stores in the TOC and Join the near stats table using the CONAME field. Resave layer as C:/Temp/Gun_Violence/Gun_Stores_Near_Crime.
7. Open the attribute table for the Gun_Stores_Near_Crime layer and sort the SUM_COUNT field in descending order. You can see that the US Pawn Jewelry & Guns store has the most crime incidents that are close to it. You can further filter the types of crime to choose ones most likely to involve a gun (assault or defense). Also, if you sort SalesVol field in descending order, you can see the Gunster Yoakley & Stewart PA store has the highest volume of sales in our crime statistics area. This analysis allows you to explore possible connections to gun access and crime and may point you in the right direction to find more data for analysis (such as gun store sales records from US Pawn Jewelry & Guns and Gunster Yoakley & Stewart PA.
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